Redmine upgrade проблемы версий

Как проапгрейдить редмайн написано на оф. сайте:
http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade

Русская версия несколько отличается и менее полная, поэтому я ей бы не доверял.

Особенности: – все указанное там стоит выполнять в том же порядке, вот только нужно не забыть удалить Gemfile.lock и выполнить:

root@redmine www/redmine# bundle install
root@redmine www/redmine# bundle update rake

После чего, все зависимости наконец станут на места.


Часто советуют инсталлить все ручками или проверять каждый джем, на что у меня ушла куча времени.
Куда легче сделать:

root@redmine www/redmine# gem update

После чего обновятся все джемы:

Вывод - и очень много буков

Updating installed gems
Updating activeresource
Fetching: rails-observers-0.1.2.gem (100%)
Fetching: activeresource-4.0.0.gem (100%)
Successfully installed rails-observers-0.1.2
Successfully installed activeresource-4.0.0
Updating atomic
Fetching: atomic-1.1.16.gem (100%)
Building native extensions. This could take a while...
Successfully installed atomic-1.1.16
Updating builder
Fetching: builder-3.2.2.gem (100%)
Successfully installed builder-3.2.2
Updating bundler
Fetching: bundler-1.6.3.gem (100%)
Successfully installed bundler-1.6.3
Updating coderay
Fetching: coderay-1.1.0.gem (100%)
Successfully installed coderay-1.1.0
Updating coffee-rails
Fetching: coffee-rails-4.0.1.gem (100%)
Successfully installed coffee-rails-4.0.1
Updating coffee-script-source
Fetching: coffee-script-source-1.7.0.gem (100%)
Successfully installed coffee-script-source-1.7.0
Updating daemon_controller
Fetching: daemon_controller-1.2.0.gem (100%)
Successfully installed daemon_controller-1.2.0
Updating execjs
Fetching: execjs-2.2.0.gem (100%)
Successfully installed execjs-2.2.0
Updating hike
Fetching: hike-2.1.3.gem (100%)
Successfully installed hike-2.1.3
Updating jbuilder
Fetching: jbuilder-2.1.1.gem (100%)
Successfully installed jbuilder-2.1.1
Updating jquery-rails
Fetching: jquery-rails-3.1.0.gem (100%)
Successfully installed jquery-rails-3.1.0
Updating json
Fetching: json-1.8.1.gem (100%)
Building native extensions. This could take a while...
Successfully installed json-1.8.1
Updating mail
Fetching: mail-2.6.1.gem (100%)
Successfully installed mail-2.6.1
Updating metaclass
Fetching: metaclass-0.0.4.gem (100%)
Successfully installed metaclass-0.0.4
Updating mime-types
Fetching: mime-types-2.3.gem (100%)
Successfully installed mime-types-2.3
Updating mocha
Fetching: mocha-1.1.0.gem (100%)
Successfully installed mocha-1.1.0
Updating multi_json
Fetching: multi_json-1.10.1.gem (100%)
Successfully installed multi_json-1.10.1
Updating mysql2
Fetching: mysql2-0.3.16.gem (100%)
Building native extensions. This could take a while...
Successfully installed mysql2-0.3.16
Updating net-ldap
Fetching: net-ldap-0.6.1.gem (100%)
Successfully installed net-ldap-0.6.1
Updating paperclip
Fetching: paperclip-4.1.1.gem (100%)
Successfully installed paperclip-4.1.1
Updating passenger
Fetching: passenger-4.0.45.gem (100%)
Building native extensions. This could take a while...
Successfully installed passenger-4.0.45
Updating pg
Fetching: pg-0.17.1.gem (100%)
Building native extensions. This could take a while...
Successfully installed pg-0.17.1
Updating polyglot
Fetching: polyglot-0.3.5.gem (100%)
Successfully installed polyglot-0.3.5
Updating rack-openid
Fetching: rack-openid-1.4.2.gem (100%)
Successfully installed rack-openid-1.4.2
Updating rack-ssl
Fetching: rack-ssl-1.4.1.gem (100%)
Successfully installed rack-ssl-1.4.1
Updating rake
Fetching: rake-10.3.2.gem (100%)
Successfully installed rake-10.3.2
Updating rdoc
Fetching: rdoc-4.1.1.gem (100%)
Depending on your version of ruby, you may need to install ruby rdoc/ri data:
<= 1.8.6 : unsupported
 = 1.8.7 : gem install rdoc-data; rdoc-data --install
 = 1.9.1 : gem install rdoc-data; rdoc-data --install
>= 1.9.2 : nothing to do! Yay!
Successfully installed rdoc-4.1.1
Updating ruby-openid
Fetching: ruby-openid-2.5.0.gem (100%)
Successfully installed ruby-openid-2.5.0
Updating sass-rails
Fetching: sass-rails-4.0.3.gem (100%)
Successfully installed sass-rails-4.0.3
Updating sdoc
Fetching: sdoc-0.4.0.gem (100%)
Successfully installed sdoc-0.4.0
Updating shoulda
Fetching: shoulda-context-1.2.1.gem (100%)
Fetching: shoulda-matchers-2.6.1.gem (100%)
Fetching: shoulda-3.5.0.gem (100%)
Successfully installed shoulda-context-1.2.1
Successfully installed shoulda-matchers-2.6.1
Successfully installed shoulda-3.5.0
Updating sprockets
Fetching: sprockets-2.12.1.gem (100%)
Successfully installed sprockets-2.12.1
Updating sprockets-rails
Fetching: sprockets-rails-2.1.3.gem (100%)
Successfully installed sprockets-rails-2.1.3
Updating sqlite3
Fetching: sqlite3-1.3.9.gem (100%)
Building native extensions. This could take a while...
Successfully installed sqlite3-1.3.9
Updating therubyracer
Fetching: therubyracer-0.12.1.gem (100%)
Building native extensions. This could take a while...
Successfully installed therubyracer-0.12.1
Updating thor
Fetching: thor-0.19.1.gem (100%)
Successfully installed thor-0.19.1
Updating thread_safe
Fetching: thread_safe-0.3.4.gem (100%)
Successfully installed thread_safe-0.3.4
Updating tilt
Fetching: tilt-2.0.1.gem (100%)
Successfully installed tilt-2.0.1
Updating treetop
Fetching: treetop-1.5.3.gem (100%)
Successfully installed treetop-1.5.3
Updating turbolinks
Fetching: turbolinks-2.2.2.gem (100%)
Successfully installed turbolinks-2.2.2
Updating uglifier
Fetching: uglifier-2.5.1.gem (100%)
Successfully installed uglifier-2.5.1
Updating yard
Fetching: yard-0.8.7.4.gem (100%)
Successfully installed yard-0.8.7.4
Gems updated: rails-observers, activeresource, atomic, builder, bundler, coderay, coffee-rails, coffee-script-source, daemon_controller, execjs, hike, jbuilder, jquery-rails, json, mail, metaclass, mime-types, mocha, multi_json, mysql2, net-ldap, paperclip, passenger, pg, polyglot, rack-openid, rack-ssl, rake, rdoc, ruby-openid, sass-rails, sdoc, shoulda-context, shoulda-matchers, shoulda, sprockets, sprockets-rails, sqlite3, therubyracer, thor, thread_safe, tilt, treetop, turbolinks, uglifier, yard
Installing ri documentation for rails-observers-0.1.2...
Building YARD (yri) index for rails-observers-0.1.2...
Installing ri documentation for activeresource-4.0.0...
Building YARD (yri) index for activeresource-4.0.0...
Installing ri documentation for atomic-1.1.16...
Building YARD (yri) index for atomic-1.1.16...
Installing ri documentation for builder-3.2.2...
Building YARD (yri) index for builder-3.2.2...
Installing ri documentation for bundler-1.6.3...
Building YARD (yri) index for bundler-1.6.3...
Installing ri documentation for coderay-1.1.0...
Building YARD (yri) index for coderay-1.1.0...
Installing ri documentation for coffee-rails-4.0.1...
Building YARD (yri) index for coffee-rails-4.0.1...
Installing ri documentation for coffee-script-source-1.7.0...
Building YARD (yri) index for coffee-script-source-1.7.0...
Installing ri documentation for daemon_controller-1.2.0...
Building YARD (yri) index for daemon_controller-1.2.0...
Installing ri documentation for execjs-2.2.0...
Building YARD (yri) index for execjs-2.2.0...
Installing ri documentation for hike-2.1.3...
Building YARD (yri) index for hike-2.1.3...
Installing ri documentation for jbuilder-2.1.1...
Building YARD (yri) index for jbuilder-2.1.1...
Installing ri documentation for jquery-rails-3.1.0...
Building YARD (yri) index for jquery-rails-3.1.0...
Installing ri documentation for json-1.8.1...
Building YARD (yri) index for json-1.8.1...
Installing ri documentation for mail-2.6.1...
Building YARD (yri) index for mail-2.6.1...
Installing ri documentation for metaclass-0.0.4...
Building YARD (yri) index for metaclass-0.0.4...
Installing ri documentation for mime-types-2.3...
Building YARD (yri) index for mime-types-2.3...
Installing ri documentation for multi_json-1.10.1...
Building YARD (yri) index for multi_json-1.10.1...
Installing ri documentation for mysql2-0.3.16...
Building YARD (yri) index for mysql2-0.3.16...
Installing ri documentation for net-ldap-0.6.1...
Building YARD (yri) index for net-ldap-0.6.1...
Installing ri documentation for paperclip-4.1.1...
Building YARD (yri) index for paperclip-4.1.1...
Installing ri documentation for passenger-4.0.45...
Building YARD (yri) index for passenger-4.0.45...
Installing ri documentation for pg-0.17.1...
Building YARD (yri) index for pg-0.17.1...
Installing ri documentation for polyglot-0.3.5...
Building YARD (yri) index for polyglot-0.3.5...
Installing ri documentation for rack-openid-1.4.2...
Building YARD (yri) index for rack-openid-1.4.2...
Installing ri documentation for rack-ssl-1.4.1...
Building YARD (yri) index for rack-ssl-1.4.1...
Installing ri documentation for rake-10.3.2...
Building YARD (yri) index for rake-10.3.2...
Installing ri documentation for rdoc-4.1.1...
Building YARD (yri) index for rdoc-4.1.1...
Installing ri documentation for ruby-openid-2.5.0...
Building YARD (yri) index for ruby-openid-2.5.0...
Installing ri documentation for sass-rails-4.0.3...
Building YARD (yri) index for sass-rails-4.0.3...
Installing ri documentation for sdoc-0.4.0...
Building YARD (yri) index for sdoc-0.4.0...
Installing ri documentation for shoulda-context-1.2.1...
Building YARD (yri) index for shoulda-context-1.2.1...
Installing ri documentation for shoulda-matchers-2.6.1...
Building YARD (yri) index for shoulda-matchers-2.6.1...
Installing ri documentation for shoulda-3.5.0...
Building YARD (yri) index for shoulda-3.5.0...
Installing ri documentation for sprockets-2.12.1...
Building YARD (yri) index for sprockets-2.12.1...
Installing ri documentation for sprockets-rails-2.1.3...
Building YARD (yri) index for sprockets-rails-2.1.3...
Installing ri documentation for sqlite3-1.3.9...
Building YARD (yri) index for sqlite3-1.3.9...
Installing ri documentation for therubyracer-0.12.1...
Building YARD (yri) index for therubyracer-0.12.1...
Installing ri documentation for thor-0.19.1...
Building YARD (yri) index for thor-0.19.1...
Installing ri documentation for thread_safe-0.3.4...
Building YARD (yri) index for thread_safe-0.3.4...
Installing ri documentation for tilt-2.0.1...
Building YARD (yri) index for tilt-2.0.1...
Installing ri documentation for treetop-1.5.3...
Building YARD (yri) index for treetop-1.5.3...
Installing ri documentation for turbolinks-2.2.2...
Building YARD (yri) index for turbolinks-2.2.2...
Installing ri documentation for uglifier-2.5.1...
Building YARD (yri) index for uglifier-2.5.1...
Installing RDoc documentation for rails-observers-0.1.2...
Installing RDoc documentation for activeresource-4.0.0...
Installing RDoc documentation for atomic-1.1.16...
Installing RDoc documentation for builder-3.2.2...
Installing RDoc documentation for bundler-1.6.3...
Installing RDoc documentation for coderay-1.1.0...
Installing RDoc documentation for coffee-rails-4.0.1...
Installing RDoc documentation for coffee-script-source-1.7.0...
Installing RDoc documentation for daemon_controller-1.2.0...
Installing RDoc documentation for execjs-2.2.0...
Installing RDoc documentation for hike-2.1.3...
Installing RDoc documentation for jbuilder-2.1.1...
Installing RDoc documentation for jquery-rails-3.1.0...
Installing RDoc documentation for json-1.8.1...
Installing RDoc documentation for mail-2.6.1...
Installing RDoc documentation for metaclass-0.0.4...
Installing RDoc documentation for mime-types-2.3...
Installing YARD documentation for mocha-1.1.0...
Installing RDoc documentation for multi_json-1.10.1...
Installing RDoc documentation for mysql2-0.3.16...
Installing RDoc documentation for net-ldap-0.6.1...
Installing RDoc documentation for paperclip-4.1.1...
Installing RDoc documentation for passenger-4.0.45...
Installing RDoc documentation for pg-0.17.1...
Installing RDoc documentation for polyglot-0.3.5...
Installing RDoc documentation for rack-openid-1.4.2...
Installing RDoc documentation for rack-ssl-1.4.1...
Installing RDoc documentation for rake-10.3.2...
Installing RDoc documentation for rdoc-4.1.1...
Installing RDoc documentation for ruby-openid-2.5.0...
Installing RDoc documentation for sass-rails-4.0.3...
Installing RDoc documentation for sdoc-0.4.0...
Installing RDoc documentation for shoulda-context-1.2.1...
Installing RDoc documentation for shoulda-matchers-2.6.1...
Installing RDoc documentation for shoulda-3.5.0...
Installing RDoc documentation for sprockets-2.12.1...
Installing RDoc documentation for sprockets-rails-2.1.3...
Installing RDoc documentation for sqlite3-1.3.9...
Installing RDoc documentation for therubyracer-0.12.1...
Installing RDoc documentation for thor-0.19.1...
Installing RDoc documentation for thread_safe-0.3.4...
Installing RDoc documentation for tilt-2.0.1...
Installing RDoc documentation for treetop-1.5.3...
Installing RDoc documentation for turbolinks-2.2.2...
Installing RDoc documentation for uglifier-2.5.1...
Installing YARD documentation for yard-0.8.7.4...

После чего, рекомендованная команда выполняется без ошибок:

root@redmine www/redmine# bundle install --without development test
root@redmine www/redmine# bundle update rake

Но тем не менее, могут остаться еще бока:

root@redmine www/redmine# rake generate_secret_token
rake aborted!
Gem::LoadError: You have already activated rake 10.3.2, but your Gemfile requires rake 10.1.1. Prepending `bundle exec` to your command may solve this.
/var/lib/gems/1.9.1/gems/bundler-1.6.3/lib/bundler/runtime.rb:34:in `block in setup'
/var/lib/gems/1.9.1/gems/bundler-1.6.3/lib/bundler/runtime.rb:19:in `setup'
/var/lib/gems/1.9.1/gems/bundler-1.6.3/lib/bundler.rb:120:in `setup'
/var/lib/gems/1.9.1/gems/bundler-1.6.3/lib/bundler/setup.rb:7:in `<top (required)>'
/var/www/redmine/config/boot.rb:6:in `<top (required)>'
/var/www/redmine/config/application.rb:1:in `<top (required)>'
/var/www/redmine/Rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)

Советует использовать приставку: undle exec – вывод прошел молча и без ошибок:

root@redmine www/redmine# bundle exec rake generate_secret_token
root@redmine www/redmine#

Заработало! Два часа убил:

Environment:
  Redmine version                2.5.1.stable
  Ruby version                   1.9.3-p194 (2012-04-20) [x86_64-linux]
  Rails version                  3.2.17
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.6.17
  Mercurial                      2.2.2
  Bazaar                         2.6.0
  Git                            1.7.10.4
  Filesystem                     
Redmine plugins:
  no plugin installed

 

 

 

About trianglesis

Александр Брюндтзвельт - гений, филантроп, 100 гривен в кармане. Этот блог - "сток" моих мыслей и заметок. Достаточно одного взгляда на него, чтобы понять, что такой же бардак творится у меня в голове. Если вам этот бардак интересен - милости прошу.
Bookmark the permalink.